-社壊人の物語-

徒然日記

PROFILE
えの


CATEGORY


RECENT ENTRIES


RECENT COMMENTS


RECENT TRACKBACKS


MONTHLY ARCHIVES


LINKS

SEARCH THIS SITE
スポンサーサイト
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

【--/--/-- (--) --:--】 スポンサー広告
このページの先頭へ
わけわかめ
昨日家のマシンにApache2.2とPHP5.2.9を入れようと
悪戦苦闘していた時の話。

ネットで調べながらやっていたのだけど、Apache2で
PHP5の設定はこうやる!的なサイトを見つけて
同じ手順でやっても上手くいかなかった。

最終的にphpmyFAQというものを使ってみたかったのだけど
その前段であるPHPとApacheの設定で四苦八苦するとは・・・。

で、結果的にはphpmyFAQが動くようにはなった。


以下、躓いた所


【httpd.conf】

LoadModule php5_module “c:/php5/php5apache2.dll”

LoadModule php5_module “c:/php5/php5apache2_2.dll


【php.ini】
extension=php_pdo_pgsql.dll
extension=php_pgsql.dll

ここが一番苦戦した。
DBにPostgreSQLを使っていて、PostgreSQL自体は動いていたけど
phpinfo()で見ても一覧に設定が出てこなかった。

調べた結果、5.2.9のDLLがおかしいらしく
5.2.5を落としてきて当該DLLのみ差し替えたら普通に動いた!



さて、今度はVMで動かそうかn
【2009/03/18 (Wed) 10:24】 Diary // TRACKBACK(0) // COMMENT(2)
このページの先頭へ
この記事に対するコメント
バージョンが変わってたりするとパッケージの名前が微妙に違ったりしてその手の設定はよくミスりますよね^^;
あまりphpは使わないけどやっぱpukiwikiは便利だから入れてしまう
【2009/03/19 (Thu) 20:51】 URL // kouma #/4W0DlUs [ 編集 ]

バージョンによって結構違うみたいだねぇ
初めて触ったからその辺の知識が全く・・・。

pukiwikiってPHPで作られてるのね!
【2009/03/23 (Mon) 15:39】 URL // えの #dGreqikc [ 編集 ]












管理者にだけ表示を許可する

このページの先頭へ
| BLOG TOP |
この記事に対するトラックバック
http://eno3.blog3.fc2.com/tb.php/855-db891285
このページの先頭へ
/
Powered by FC2ブログ / Template by chocolat*
Copyright © 2005 徒然日記 All Rights Reserved.
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。